A. We recommend an OS – Windows 7 or later version; and the Chrome, IE 10 or later version, or Firefox browsers.

 

Was this helpful? Leave a comment below